RSSN has Arbitrary Code Execution via Unvalidated JIT Instruction Generation in C-FFI Interface
CVE-2026-30960GHSA-9c4h-pwmf-m6fj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rssn 0.2.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io rssn
- Affected
- < 0.2.9
- Fixed in
- 0.2.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9c4h-pwmf-m6fj lists affected ranges: crates.io rssn >=0 <0.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-30960: 0.20% estimated exploitation activity in the next 30 days; percentile 10.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Vulnerability Type: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). Technical Details: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. Who is Impacted? Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g.,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9c4h-pwmf-m6fj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30960 Advisory: RSSN has Arbitrary Code Execution via Unvalidated JIT Instruction Generation in C-FFI Interface IDs: CVE-2026-30960, GHSA-9c4h-pwmf-m6fj Record: https://patchnext.com/advisories/cve-2026-30960 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rssn 0.2.9. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io rssn: affected < 0.2.9; fixed in 0.2.9 ## Suggested inspection (read-only) - crates.io rssn: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rssn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9c4h-pwmf-m6fj (GitHub-reviewed advisory GHSA-9c4h-pwmf-m6fj lists affected ranges: crates.io rssn >=0 <0.2.9) Commands are suggestions: review each one before running it.
Loading voting…