Skip to content

← Actionable
Critical, CVSS 9.9amended

OneUptime has authorization bypass via client‑controlled is-multi-tenant-query header that leads to cross‑tenant data exposure and account takeover

CVE-2026-30956GHSA-r5v6-2599-9g3m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@oneuptime/common 10.0.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-30956: 0.51% estimated exploitation activity in the next 30 days; percentile 43.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A low‑privileged user can bypass authorization and tenant isolation in OneUptime v10.0.20 by sending a forged is-multi-tenant-query header together with a controlled projectid header. Because the server trusts this client-supplied header, internal permission checks in BasePermission are skipped and tenant scoping is disabled. This allows attackers to: 1. Access project data belonging to other tenants 2. Read sensitive User fields via nested relations 3. Leak plaintext resetPasswordToken 4. Reset the victim’s password and fully take over the account This results in cross‑tenant data exposure and full account takeover. Details Root cause The API trusts a client‑controlled header to determine whether a request should bypass authorization checks. CommonAPI.ts BasePermission.ts When the attacker sends: the system skips all authorization checks including: - Table permission validation - Query permission validation - Select permission validation - Tenant isolation enforcement…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r5v6-2599-9g3m

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r5v6-2599-9g3m

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r5v6-2599-9g3m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30956

Advisory: OneUptime has authorization bypass via client‑controlled is-multi-tenant-query header that leads to cross‑tenant data exposure and account takeover
IDs: CVE-2026-30956, GHSA-r5v6-2599-9g3m
Record: https://patchnext.com/advisories/cve-2026-30956 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @oneuptime/common 10.0.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @oneuptime/common: affected < 10.0.21; fixed in 10.0.21

## Suggested inspection (read-only)
- `npm ls @oneuptime/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @oneuptime/common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5v6-2599-9g3m (GitHub-reviewed advisory GHSA-r5v6-2599-9g3m lists affected ranges: npm @oneuptime/common >=0 <10.0.21)
- Verified: https://osv.dev/vulnerability/GHSA-r5v6-2599-9g3m (OSV record GHSA-r5v6-2599-9g3m lists affected ranges: npm @oneuptime/common >=0 <10.0.21 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…