Skip to content

← Actionable
High, CVSS 7.5amended

Sequelize v6 Vulnerable to SQL Injection via JSON Column Cast Type

CVE-2026-30951GHSA-6457-6jrx-69cr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 6.37.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sequelize

    Affected
    >= 6.0.0-beta.1, <= 6.37.7
    Fixed in
    6.37.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-30951: 0.45% estimated exploitation activity in the next 30 days; percentile 39.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SQL injection via unescaped cast type in JSON/JSONB where clause processing. The traverseJSON() function splits JSON path keys on :: to extract a cast type, which is interpolated raw into CAST(... AS <type) SQL. An attacker who controls JSON object keys can inject arbitrary SQL and exfiltrate data from any table. Affected: v6.x through 6.37.7. v7 (@sequelize/core) is not affected. Details In src/dialects/abstract/query-generator.js, traverseJSON() extracts a cast type from :: in JSON keys without validation: castKey() (line 1925) passes it to Utils.Cast, and handleSequelizeMethod() (line 1692) interpolates it directly: JSON path values are escaped via this.escape() in jsonPathExtractionQuery(), but the cast type is not. Suggested fix — whitelist known SQL data types: PoC npm install sequelize@6.37.7 sqlite3 Output: Impact SQL Injection (CWE-89) — Any application that passes user-controlled objects as where clause values for JSON/JSONB columns is vulnerable. An attacker can…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6457-6jrx-69cr

  2. Revision 1 · created ·

    Published from osv record GHSA-6457-6jrx-69cr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30951

Advisory: Sequelize v6 Vulnerable to SQL Injection via JSON Column Cast Type
IDs: CVE-2026-30951, GHSA-6457-6jrx-69cr
Record: https://patchnext.com/advisories/cve-2026-30951 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sequelize 6.37.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sequelize: affected >= 6.0.0-beta.1, <= 6.37.7; fixed in 6.37.8

## Suggested inspection (read-only)
- `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sequelize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6457-6jrx-69cr (OSV record GHSA-6457-6jrx-69cr lists affected ranges: npm sequelize >=6.0.0-beta.1 <6.37.8 (fixed))
- Verified: https://github.com/advisories/GHSA-6457-6jrx-69cr (GitHub-reviewed advisory GHSA-6457-6jrx-69cr lists affected ranges: npm sequelize >=6.0.0-beta.1 <=6.37.7)

Commands are suggestions: review each one before running it.

Loading voting…