Parse Server missing audience validation in Keycloak authentication adapter
CVE-2026-30949GHSA-48mh-j4p5-7j9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.2-alpha.5, 8.6.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.5.2-alpha.5< 8.6.18
- Fixed in
- 8.6.18, 9.5.2-alpha.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-48mh-j4p5-7j9v lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48mh-j4p5-7j9v lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-30949: 0.45% estimated exploitation activity in the next 30 days; percentile 39.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. Patches The fix replaces the userinfo HTTP call with local JWT verification and enforces azp claim validation against the configured client-id. Workarounds None. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-48mh-j4p5-7j9v - Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.5 - Fix Parse Server 8:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-48mh-j4p5-7j9v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-48mh-j4p5-7j9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30949 Advisory: Parse Server missing audience validation in Keycloak authentication adapter IDs: CVE-2026-30949, GHSA-48mh-j4p5-7j9v Record: https://patchnext.com/advisories/cve-2026-30949 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.2-alpha.5, 8.6.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.5.2-alpha.5; < 8.6.18; fixed in 8.6.18, 9.5.2-alpha.5 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-48mh-j4p5-7j9v (OSV record GHSA-48mh-j4p5-7j9v lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.18 (fixed)) - Verified: https://github.com/advisories/GHSA-48mh-j4p5-7j9v (GitHub-reviewed advisory GHSA-48mh-j4p5-7j9v lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.18) Commands are suggestions: review each one before running it.
Loading voting…