Skip to content

← Actionable
High, CVSS 8.7amended

Parse Server has a NoSQL injection via token type in password reset and email verification endpoints

CVE-2026-30941GHSA-vgjh-hmwf-c588

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.2-alpha.1, 8.6.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.5.2-alpha.1< 8.6.14
    Fixed in
    9.5.2-alpha.1, 8.6.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30941: 0.47% estimated exploitation activity in the next 30 days; percentile 40.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A NoSQL injection vulnerability allows an unauthenticated attacker to inject MongoDB query operators via the token field in the password reset and email verification resend endpoints. The token value is passed to database queries without type validation and can be used to extract password reset and email verification tokens. Any Parse Server deployment using MongoDB with email verification or password reset enabled is affected. When emailVerifyTokenReuseIfValid is configured, the email verification token can be fully extracted and used to verify a user's email address without inbox access. Patches Patches The vulnerability is fixed by adding input type validation at the endpoint level. Workarounds There is no known workaround. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-vgjh-hmwf-c588 - Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.1 - Fix Parse Server 8:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vgjh-hmwf-c588

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vgjh-hmwf-c588

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30941

Advisory: Parse Server has a NoSQL injection via token type in password reset and email verification endpoints
IDs: CVE-2026-30941, GHSA-vgjh-hmwf-c588
Record: https://patchnext.com/advisories/cve-2026-30941 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.2-alpha.1, 8.6.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.5.2-alpha.1; < 8.6.14; fixed in 9.5.2-alpha.1, 8.6.14

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vgjh-hmwf-c588 (OSV record GHSA-vgjh-hmwf-c588 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.14 (fixed))
- Verified: https://github.com/advisories/GHSA-vgjh-hmwf-c588 (GitHub-reviewed advisory GHSA-vgjh-hmwf-c588 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.14)

Commands are suggestions: review each one before running it.

Loading voting…