Skip to content

← Actionable
Medium, CVSS 6.9amended

Parse Server has denylist requestKeywordDenylist keyword scan bypass through nested object placement

CVE-2026-30938GHSA-q342-9w2p-57fp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.1-alpha.1, 8.6.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 8.6.12>= 9.0.0-alpha.1, < 9.5.1-alpha.1
    Fixed in
    8.6.12, 9.5.1-alpha.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30938: 0.42% estimated exploitation activity in the next 30 days; percentile 36.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The requestKeywordDenylist security control can be bypassed by placing any nested object or array before a prohibited keyword in the request payload. This is caused by a logic bug that stops scanning sibling keys after encountering the first nested value. Any custom requestKeywordDenylist entries configured by the developer are equally by-passable using the same technique. All Parse Server deployments are affected. The requestKeywordDenylist is enabled by default. Patches The fix replaces the recursive object scanner with an iterative stack-based traversal that processes all nested values without prematurely exiting the scan loop. This also eliminates a potential stack overflow on deeply nested payloads. Workarounds Use a Cloud Code beforeSave trigger to validate incoming data for prohibited keywords across all classes. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-q342-9w2p-57fp - Fix Parse Server 9:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q342-9w2p-57fp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q342-9w2p-57fp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30938

Advisory: Parse Server has denylist `requestKeywordDenylist` keyword scan bypass through nested object placement
IDs: CVE-2026-30938, GHSA-q342-9w2p-57fp
Record: https://patchnext.com/advisories/cve-2026-30938 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.1-alpha.1, 8.6.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 8.6.12; >= 9.0.0-alpha.1, < 9.5.1-alpha.1; fixed in 8.6.12, 9.5.1-alpha.1

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q342-9w2p-57fp (OSV record GHSA-q342-9w2p-57fp lists affected ranges: npm parse-server >=0 =9.0.0-alpha.1 <9.5.1-alpha.1 (fixed))
- Verified: https://github.com/advisories/GHSA-q342-9w2p-57fp (GitHub-reviewed advisory GHSA-q342-9w2p-57fp lists affected ranges: npm parse-server >=0 =9.0.0-alpha.1 <9.5.1-alpha.1)

Commands are suggestions: review each one before running it.

Loading voting…