Skip to content

← Actionable
High, CVSS 7.5amended

Denial of Service in pyasn1 via Unbounded Recursion

CVE-2026-30922GHSA-jr27-m4p2-rc6r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyasn1 0.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyasn1

    Affected
    <= 0.6.2
    Fixed in
    0.6.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-30922: 0.82% estimated exploitation activity in the next 30 days; percentile 57.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The pyasn1 library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deeply nested structures. An attacker can supply a crafted payload containing nested SEQUENCE (0x30) or SET (0x31) tags with Indefinite Length (0x80) markers. This forces the decoder to recursively call itself until the Python interpreter crashes with a RecursionError or consumes all available memory (OOM), crashing the host application. Details The vulnerability exists because the decoder iterates through the input stream and recursively calls decodeFun (the decoding callback) for every nested component found, without tracking or limiting the recursion depth. Vulnerable Code Locations: 1. indefLenValueDecoder (Line 998): This method handles indefinite-length constructed types. It sits inside a while True loop and recursively calls the decoder for every nested tag. 2. valueDecoder (Lines 786 and 907): This method handles standard decoding when a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jr27-m4p2-rc6r

  2. Revision 1 · created ·

    Published from osv record GHSA-jr27-m4p2-rc6r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30922

Advisory: Denial of Service in pyasn1 via Unbounded Recursion
IDs: CVE-2026-30922, GHSA-jr27-m4p2-rc6r
Record: https://patchnext.com/advisories/cve-2026-30922 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyasn1 0.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyasn1: affected <= 0.6.2; fixed in 0.6.3

## Suggested inspection (read-only)
- `python -m pip show pyasn1`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyasn1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jr27-m4p2-rc6r (OSV record GHSA-jr27-m4p2-rc6r lists affected ranges: PyPI pyasn1 >=0 <0.6.3 (fixed))
- Verified: https://github.com/advisories/GHSA-jr27-m4p2-rc6r (GitHub-reviewed advisory GHSA-jr27-m4p2-rc6r lists affected ranges: PyPI pyasn1 >=0 <=0.6.2)

Commands are suggestions: review each one before running it.

Loading voting…