OneUptime: Synthetic Monitor RCE via exposed Playwright browser object
CVE-2026-30921GHSA-4j36-39gm-8vq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@oneuptime/common 10.0.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 10.0.20
- Fixed in
- 10.0.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4j36-39gm-8vq8 lists affected ranges: npm @oneuptime/common >=0 <10.0.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4j36-39gm-8vq8 lists affected ranges: npm @oneuptime/common >=0 <10.0.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-30921: 0.46% estimated exploitation activity in the next 30 days; percentile 40.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OneUptime Synthetic Monitors allow low-privileged project users to submit custom Playwright code that is executed on the oneuptime-probe service. In the current implementation, this untrusted code is run inside Node's vm and is given live host Playwright objects such as browser and page. This creates a distinct server-side RCE primitive: the attacker does not need the classic this.constructor.constructor(...) sandbox escape. Instead, the attacker can directly use the injected Playwright browser object to reach browser.browserType().launch(...) and spawn an arbitrary executable on the probe host/container. This appears to be a separate issue from the previously published node:vm(GHSA-h343-gg57-2q67) breakout advisory because the root cause here is exposure of a dangerous host capability object to untrusted code, not prototype-chain access to process. Details A normal project member can create or edit monitors and monitor tests: -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4j36-39gm-8vq8
- Revision 2 · amended ·
Amended from osv record GHSA-4j36-39gm-8vq8
- Revision 1 · created ·
Published from ghsa record GHSA-4j36-39gm-8vq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30921 Advisory: OneUptime: Synthetic Monitor RCE via exposed Playwright browser object IDs: CVE-2026-30921, GHSA-4j36-39gm-8vq8 Record: https://patchnext.com/advisories/cve-2026-30921 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @oneuptime/common 10.0.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @oneuptime/common: affected < 10.0.20; fixed in 10.0.20 ## Suggested inspection (read-only) - `npm ls @oneuptime/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @oneuptime/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4j36-39gm-8vq8 (GitHub-reviewed advisory GHSA-4j36-39gm-8vq8 lists affected ranges: npm @oneuptime/common >=0 <10.0.20) - Verified: https://osv.dev/vulnerability/GHSA-4j36-39gm-8vq8 (OSV record GHSA-4j36-39gm-8vq8 lists affected ranges: npm @oneuptime/common >=0 <10.0.20 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…