OneUpTime's Unsandboxed Code Execution in Probe Allows Any Project Member to Achieve RCE
CVE-2026-30887GHSA-h343-gg57-2q67
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@oneuptime/common 10.0.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 10.0.18
- Fixed in
- 10.0.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h343-gg57-2q67 lists affected ranges: npm @oneuptime/common >=0 <10.0.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h343-gg57-2q67 lists affected ranges: npm @oneuptime/common >=0 <10.0.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-30887: 0.41% estimated exploitation activity in the next 30 days; percentile 35.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OneUptime allows project members to run custom Playwright/JavaScript code via Synthetic Monitors to test websites. However, the system executes this untrusted user code inside the insecure Node.js vm module. By leveraging a standard prototype-chain escape (this.constructor.constructor), an attacker can bypass the sandbox, gain access to the underlying Node.js process object, and execute arbitrary system commands (RCE) on the oneuptime-probe container. Furthermore, because the probe holds database/cluster credentials in its environment variables, this directly leads to a complete cluster compromise. Details The root cause of the vulnerability exists in Common/Server/Utils/VM/VMRunner.ts where user-supplied JavaScript is executed using vm.runInContext(): The Node.js documentation explicitly warns that the vm module is not a security boundary and should never be used to run untrusted code. When a user creates a Synthetic Monitor, the code inputted into the Playwright script…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h343-gg57-2q67
- Revision 2 · amended ·
Amended from osv record GHSA-h343-gg57-2q67
- Revision 1 · created ·
Published from ghsa record GHSA-h343-gg57-2q67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30887 Advisory: OneUpTime's Unsandboxed Code Execution in Probe Allows Any Project Member to Achieve RCE IDs: CVE-2026-30887, GHSA-h343-gg57-2q67 Record: https://patchnext.com/advisories/cve-2026-30887 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @oneuptime/common 10.0.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @oneuptime/common: affected < 10.0.18; fixed in 10.0.18 ## Suggested inspection (read-only) - `npm ls @oneuptime/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @oneuptime/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h343-gg57-2q67 (GitHub-reviewed advisory GHSA-h343-gg57-2q67 lists affected ranges: npm @oneuptime/common >=0 <10.0.18) - Verified: https://osv.dev/vulnerability/GHSA-h343-gg57-2q67 (OSV record GHSA-h343-gg57-2q67 lists affected ranges: npm @oneuptime/common >=0 <10.0.18 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…