PowerSync: Some sync filters ignored on 1.20.0 using config.edition: 3
CVE-2026-30870GHSA-q6wc-xx4m-92fj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@powersync/service-core 1.20.1; @powersync/service-sync-rules 0.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.20.0, <= 1.20.0
- Fixed in
- 1.20.1
npm @powersync/service-sync-rules
- Affected
- >= 0.32.0, <= 0.32.0
- Fixed in
- 0.33.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q6wc-xx4m-92fj lists affected ranges: npm @powersync/service-core >=1.20.0 =0.32.0 <0.33.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6wc-xx4m-92fj lists affected ranges: npm @powersync/service-core >=1.20.0 =0.32.0 <=0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-30870: 0.21% estimated exploitation activity in the next 30 days; percentile 11.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In version 1.20.0, when using new sync streams with config.edition: 3, certain subquery filters were ignored when determining which data to sync to users. Depending on the sync stream configuration, this could result in authenticated users syncing data that should have been restricted. Only queries that gate synchronization using subqueries without partitioning the result set are affected. Not affected: Sync rules (bucketdefinitions) Sync streams using config.edition: 2 No data is exposed without authenticating Patches The issue is fixed in 1.20.1. Restarting the service with the new version is sufficient - no reprocessing of sync streams is required. Any data that users erroneously synced will be automatically removed from those devices when they connect again. We have updated all affected PowerSync Cloud instances to the fixed version, and are reaching out to affected customers. For self-hosted PowerSync instances, update to the latest version and restart. Affected queries…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q6wc-xx4m-92fj
- Revision 1 · created ·
Published from osv record GHSA-q6wc-xx4m-92fj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30870 Advisory: PowerSync: Some sync filters ignored on 1.20.0 using `config.edition: 3` IDs: CVE-2026-30870, GHSA-q6wc-xx4m-92fj Record: https://patchnext.com/advisories/cve-2026-30870 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @powersync/service-core 1.20.1; @powersync/service-sync-rules 0.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @powersync/service-core: affected >= 1.20.0, <= 1.20.0; fixed in 1.20.1 - npm @powersync/service-sync-rules: affected >= 0.32.0, <= 0.32.0; fixed in 0.33.0 ## Suggested inspection (read-only) - `npm ls @powersync/service-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @powersync/service-sync-rules --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @powersync/service-core, @powersync/service-sync-rules. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q6wc-xx4m-92fj (OSV record GHSA-q6wc-xx4m-92fj lists affected ranges: npm @powersync/service-core >=1.20.0 =0.32.0 <0.33.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q6wc-xx4m-92fj (GitHub-reviewed advisory GHSA-q6wc-xx4m-92fj lists affected ranges: npm @powersync/service-core >=1.20.0 =0.32.0 <=0.32.0) Commands are suggestions: review each one before running it.
Loading voting…