Skip to content

← Actionable
Critical, CVSS 9.3amended

Parse Server: JWT audience validation bypass in Google, Apple, and Facebook authentication adapters

CVE-2026-30863GHSA-x6fw-778m-wr9v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.0-alpha.11, 8.6.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0-alpha.1, < 9.5.0-alpha.11< 8.6.10
    Fixed in
    8.6.10, 9.5.0-alpha.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30863: 0.58% estimated exploitation activity in the next 30 days; percentile 47.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Google, Apple, and Facebook authentication adapters use JWT verification to validate identity tokens. When the adapter's audience configuration option is not set (clientId for Google/Apple, appIds for Facebook), JWT verification silently skips audience claim validation. This allows an attacker to use a validly signed JWT issued for a different application to authenticate as any user on the target Parse Server. - For Google and Apple, the vulnerability is exploitable when the server does not configure clientId. The adapters accepted this as valid and simply skipped audience validation. - For Facebook Limited Login, the vulnerability exists regardless of configuration. The adapter validated appIds only for Standard Login (Graph API), but the Limited Login JWT path never passed appIds as the audience to JWT verification. Patches The fix enforces clientId (Google/Apple) and appIds (Facebook) as mandatory and passes them to JWT verification for audience validation. While this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-x6fw-778m-wr9v

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-x6fw-778m-wr9v

  4. Revision 1 · created ·

    Published from ghsa record GHSA-x6fw-778m-wr9v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30863

Advisory: Parse Server: JWT audience validation bypass in Google, Apple, and Facebook authentication adapters
IDs: CVE-2026-30863, GHSA-x6fw-778m-wr9v
Record: https://patchnext.com/advisories/cve-2026-30863 (revision 4, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.0-alpha.11, 8.6.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0-alpha.1, < 9.5.0-alpha.11; < 8.6.10; fixed in 8.6.10, 9.5.0-alpha.11

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x6fw-778m-wr9v (GitHub-reviewed advisory GHSA-x6fw-778m-wr9v lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.10)
- Verified: https://osv.dev/vulnerability/GHSA-x6fw-778m-wr9v (OSV record GHSA-x6fw-778m-wr9v lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.10 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…