Skip to content

← Actionable
Medium, CVSS 6.9amended

Parse Server: GraphQL __type introspection bypass via inline fragments when public introspection is disabled

CVE-2026-30854GHSA-q5q9-2rhp-33qw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.0-alpha.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.3.1-alpha.3, < 9.5.0-alpha.10
    Fixed in
    9.5.0-alpha.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30854: 0.31% estimated exploitation activity in the next 30 days; percentile 23.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When graphQLPublicIntrospection is disabled, type queries nested inside inline fragments (e.g. ... on Query { type(name:"User") { name } }) bypass the introspection control, allowing unauthenticated users to perform type reconnaissance. schema introspection is not affected. Patches The check was changed from a flat iteration over root-level selections to a recursive walk of all selection sets, detecting type inside inline fragments at any depth. Workarounds Require master key authentication at the network layer (e.g. reverse proxy) for the GraphQL endpoint. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-q5q9-2rhp-33qw - Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.0-alpha.10

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q5q9-2rhp-33qw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q5q9-2rhp-33qw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30854

Advisory: Parse Server: GraphQL `__type` introspection bypass via inline fragments when public introspection is disabled
IDs: CVE-2026-30854, GHSA-q5q9-2rhp-33qw
Record: https://patchnext.com/advisories/cve-2026-30854 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.0-alpha.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.3.1-alpha.3, < 9.5.0-alpha.10; fixed in 9.5.0-alpha.10

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q5q9-2rhp-33qw (OSV record GHSA-q5q9-2rhp-33qw lists affected ranges: npm parse-server >=9.3.1-alpha.3 <9.5.0-alpha.10 (fixed))
- Verified: https://github.com/advisories/GHSA-q5q9-2rhp-33qw (GitHub-reviewed advisory GHSA-q5q9-2rhp-33qw lists affected ranges: npm parse-server >=9.3.1-alpha.3 <9.5.0-alpha.10)

Commands are suggestions: review each one before running it.

Loading voting…