Caddy's vars_regexp double-expands user input, leaking env vars and files
CVE-2026-30852GHSA-m2w3-8f23-hxxf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/caddyserver/caddy/v2/modules/caddyhttp 2.11.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/caddyserver/caddy/v2/modules/caddyhttp
- Affected
- >= 2.7.5, <= 2.11.1
- Fixed in
- 2.11.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m2w3-8f23-hxxf lists affected ranges: Go github.com/caddyserver/caddy/v2/modules/caddyhttp >=2.7.5 <=2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-30852: 0.47% estimated exploitation activity in the next 30 days; percentile 40.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The varsregexp matcher in vars.go:337 double-expands user-controlled input through the Caddy replacer. When varsregexp matches against a placeholder like {http.request.header.X-Input}, the header value gets resolved once (expected), then passed through repl.ReplaceAll() again (the bug). This means an attacker can put {env.DATABASEURL} or {file./etc/passwd} in a request header and the server will evaluate it, leaking environment variables, file contents, and system info. headerregexp does NOT do this — it passes header values straight to Match(). So this is a code-level inconsistency, not intended behavior. Details The bug is at modules/caddyhttp/vars.go, line 337 in MatchVarsRE.MatchWithError(): When the key is a placeholder like {http.request.header.X-Input}, repl.Get() resolves it to the raw header value (first expansion, line 318). Then repl.ReplaceAll() runs on that value again (second expansion, line 337), which evaluates any {env.}, {file.}, {system.} placeholders the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m2w3-8f23-hxxf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30852 Advisory: Caddy's vars_regexp double-expands user input, leaking env vars and files IDs: CVE-2026-30852, GHSA-m2w3-8f23-hxxf Record: https://patchnext.com/advisories/cve-2026-30852 (revision 1, source checked 26 Oct 2026, 15:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/caddyserver/caddy/v2/modules/caddyhttp 2.11.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/caddyserver/caddy/v2/modules/caddyhttp: affected >= 2.7.5, <= 2.11.1; fixed in 2.11.2 ## Suggested inspection (read-only) - Go github.com/caddyserver/caddy/v2/modules/caddyhttp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/caddyserver/caddy/v2/modules/caddyhttp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m2w3-8f23-hxxf (GitHub-reviewed advisory GHSA-m2w3-8f23-hxxf lists affected ranges: Go github.com/caddyserver/caddy/v2/modules/caddyhttp >=2.7.5 <=2.11.1) Commands are suggestions: review each one before running it.
Loading voting…