Skip to content

← Actionable
Medium, CVSS 6.3amended

Parse Server: PagesRouter path traversal allows reading files outside configured pages directory

CVE-2026-30848GHSA-hm3f-q6rw-m6wh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.0-alpha.8, 8.6.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 8.6.8>= 9.0.0-alpha.1, < 9.5.0-alpha.8
    Fixed in
    8.6.8, 9.5.0-alpha.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30848: 0.35% estimated exploitation activity in the next 30 days; percentile 28.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The PagesRouter static file serving route is vulnerable to a path traversal attack that allows unauthenticated reading of files outside the configured pagesPath directory. The boundary check uses a string prefix comparison without enforcing a directory separator boundary. An attacker can use path traversal sequences to access files in sibling directories whose names share the same prefix as the pages directory (e.g. pages-secret starts with pages). This affects any Parse Server deployment with the pages feature enabled (pages.enableRouter: true). Exploitation requires a sibling directory of pagesPath whose name begins with the same string as the pages directory name. Patches The fix enforces a path separator boundary in the check, ensuring resolved paths must be strictly inside the pagesPath directory. Workarounds Ensure the pagesPath directory has no sibling directories whose names begin with the same prefix. For example, if pagesPath is /srv/pages, ensure no directory like…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hm3f-q6rw-m6wh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hm3f-q6rw-m6wh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30848

Advisory: Parse Server: `PagesRouter` path traversal allows reading files outside configured pages directory
IDs: CVE-2026-30848, GHSA-hm3f-q6rw-m6wh
Record: https://patchnext.com/advisories/cve-2026-30848 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.0-alpha.8, 8.6.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 8.6.8; >= 9.0.0-alpha.1, < 9.5.0-alpha.8; fixed in 8.6.8, 9.5.0-alpha.8

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hm3f-q6rw-m6wh (OSV record GHSA-hm3f-q6rw-m6wh lists affected ranges: npm parse-server >=0 =9.0.0-alpha.1 <9.5.0-alpha.8 (fixed))
- Verified: https://github.com/advisories/GHSA-hm3f-q6rw-m6wh (GitHub-reviewed advisory GHSA-hm3f-q6rw-m6wh lists affected ranges: npm parse-server >=0 =9.0.0-alpha.1 <9.5.0-alpha.8)

Commands are suggestions: review each one before running it.

Loading voting…