Skip to content

← Actionable
Critical, CVSS 10.0

step-ca has Unauthenticated Certificate Issuance via SCEP UpdateReq (MessageType=18)

CVE-2026-30836GHSA-q4r8-xm5f-56gw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/smallstep/certificates 0.30.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-30836: 0.31% estimated exploitation activity in the next 30 days; percentile 23.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An attacker can force a Step CA SCEP provisioner to create certificates without completing certain protocol authorization checks. Details SCEP requests carry a message type. On receipt of a SCEP request, Step CA starts processing it by parsing its contents. Message types that were considered valid, but not explicitly supported in Step CA, would result in getting parsed successfully. While processing the parsed SCEP message, authorization logic would be skipped for the non-supported message types. As a result, the request would be treated as authorized, bypassing the authorization checks normally enforced as part of the SCEP protocol and its implementation in Step CA. Authorization webhooks and regular CA policies, such as allowed names and restrictions on certificate validity periods, remain in place. Mitigations If you are unable to upgrade to v0.30.0 or newer, the attack can be mitigated by (temporarily) disabling or removing SCEP provisioners, or restricting access to SCEP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4r8-xm5f-56gw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30836

Advisory: step-ca has Unauthenticated Certificate Issuance via SCEP UpdateReq (MessageType=18)
IDs: CVE-2026-30836, GHSA-q4r8-xm5f-56gw
Record: https://patchnext.com/advisories/cve-2026-30836 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/smallstep/certificates 0.30.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/smallstep/certificates: affected < 0.30.0; fixed in 0.30.0

## Suggested inspection (read-only)
- Go github.com/smallstep/certificates: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/smallstep/certificates.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4r8-xm5f-56gw (GitHub-reviewed advisory GHSA-q4r8-xm5f-56gw lists affected ranges: Go github.com/smallstep/certificates >=0 <0.30.0)

Commands are suggestions: review each one before running it.

Loading voting…