Skip to content

← Actionable
Medium, CVSS 6.9amended

parse-server: Malformed $regex query leaks database error details in API response

CVE-2026-30835GHSA-9cp7-3q5w-j92g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.0-alpha.6, 8.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.5.0-alpha.6< 8.6.7
    Fixed in
    9.5.0-alpha.6, 8.6.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30835: 0.37% estimated exploitation activity in the next 30 days; percentile 31.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malformed $regex query parameter (e.g. abc) causes the database to return a structured error object that is passed unsanitized through the API response. This leaks database internals such as error messages, error codes, code names, cluster timestamps, and topology details. The vulnerability is exploitable by any client that can send query requests, depending on the deployment's permission configuration. Patches The fix sanitizes database error objects so that only a generic "An internal server error occurred" message is returned to clients, while the detailed error is logged server-side. The fix respects the enableSanitizedErrorResponse server option. Workarounds There is no workaround other than upgrading. The error leakage occurs in the query execution layer and cannot be mitigated through server configuration or client-side changes. Resources - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-9cp7-3q5w-j92g - Fix in Parse…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9cp7-3q5w-j92g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9cp7-3q5w-j92g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30835

Advisory: parse-server: Malformed `$regex` query leaks database error details in API response
IDs: CVE-2026-30835, GHSA-9cp7-3q5w-j92g
Record: https://patchnext.com/advisories/cve-2026-30835 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.0-alpha.6, 8.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.5.0-alpha.6; < 8.6.7; fixed in 9.5.0-alpha.6, 8.6.7

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9cp7-3q5w-j92g (OSV record GHSA-9cp7-3q5w-j92g lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.7 (fixed))
- Verified: https://github.com/advisories/GHSA-9cp7-3q5w-j92g (GitHub-reviewed advisory GHSA-9cp7-3q5w-j92g lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.7)

Commands are suggestions: review each one before running it.

Loading voting…