soft-serve vulnerable to SSRF via unvalidated LFS endpoint in repo import
CVE-2026-30832GHSA-3fvx-xrxq-8jvv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/charmbracelet/soft-serve 0.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/charmbracelet/soft-serve
- Affected
- >= 0.6.0, < 0.11.4
- Fixed in
- 0.11.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3fvx-xrxq-8jvv lists affected ranges: Go github.com/charmbracelet/soft-serve >=0.6.0 <0.11.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2026-30832: 0.36% estimated exploitation activity in the next 30 days; percentile 30.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
While auditing the codebase in the wake of the webhook SSRF fix shipped in v0.11.1 (GHSA-vwq2-jx9q-9h9f), it was identified that the LFS import path was never given the same treatment. The webhook fix introduced dual-layer SSRF protection — ValidateWebhookURL() at creation time and secureHTTPClient with IP validation at dial time — but the LFS HTTP client still uses http.DefaultClient with no filtering at all. Summary An authenticated SSH user can force the server to make HTTP requests to internal/private IP addresses by running repo import with a crafted --lfs-endpoint URL. The initial batch request is blind (the response from a metadata endpoint won't parse as valid LFS JSON), but an attacker hosting a fake LFS server can chain this into full read access to internal services by returning download URLs that point at internal targets. Details The user-controlled endpoint flows through four files with zero validation: 1. User supplies the URL via --lfs-endpoint…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3fvx-xrxq-8jvv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30832 Advisory: soft-serve vulnerable to SSRF via unvalidated LFS endpoint in repo import IDs: CVE-2026-30832, GHSA-3fvx-xrxq-8jvv Record: https://patchnext.com/advisories/cve-2026-30832 (revision 1, source checked 26 Oct 2026, 15:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/charmbracelet/soft-serve 0.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/charmbracelet/soft-serve: affected >= 0.6.0, < 0.11.4; fixed in 0.11.4 ## Suggested inspection (read-only) - Go github.com/charmbracelet/soft-serve: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/charmbracelet/soft-serve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3fvx-xrxq-8jvv (GitHub-reviewed advisory GHSA-3fvx-xrxq-8jvv lists affected ranges: Go github.com/charmbracelet/soft-serve >=0.6.0 <0.11.4) Commands are suggestions: review each one before running it.
Loading voting…