Skip to content

← Actionable
Low, CVSS 2.1amended

defuddle vulnerable to XSS via unescaped string interpolation in _findContentBySchemaText image tag

CVE-2026-30830GHSA-5mq8-78gm-pjmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (defuddle 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm defuddle

    Affected
    <= 0.7.0
    Fixed in
    0.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2026-30830: 0.29% estimated exploitation activity in the next 30 days; percentile 21.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The findContentBySchemaText method in src/defuddle.ts interpolates image src and alt attributes directly into an HTML string without escaping: An attacker can use a " in the alt attribute to break out of the attribute context and inject event handlers. This is a separate vulnerability from the sanitization bypass fixed in f154cb7 — the injection happens during string construction, not in the DOM, so stripUnsafeElements cannot catch it. Details When findContentBySchemaText finds a sibling image outside the matched content element, it reads the image's src and alt attributes via getAttribute() and interpolates them into a template literal. getAttribute('alt') returns the raw attribute value. If the alt contains ", it terminates the alt attribute in the interpolated HTML string, and subsequent content becomes new attributes (including event handlers). The recently added stripUnsafeElements() (commit f154cb7) strips on attributes from DOM elements, but the alt attribute's name is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5mq8-78gm-pjmq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5mq8-78gm-pjmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30830

Advisory: defuddle vulnerable to XSS via unescaped string interpolation in _findContentBySchemaText image tag
IDs: CVE-2026-30830, GHSA-5mq8-78gm-pjmq
Record: https://patchnext.com/advisories/cve-2026-30830 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: defuddle 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm defuddle: affected <= 0.7.0; fixed in 0.9.0

## Suggested inspection (read-only)
- `npm ls defuddle --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on defuddle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5mq8-78gm-pjmq (OSV record GHSA-5mq8-78gm-pjmq lists affected ranges: npm defuddle >=0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5mq8-78gm-pjmq (GitHub-reviewed advisory GHSA-5mq8-78gm-pjmq lists affected ranges: npm defuddle >=0 <=0.7.0)

Commands are suggestions: review each one before running it.

Loading voting…