express-rate-limit: IPv4-mapped IPv6 addresses bypass per-client rate limiting on servers with dual-stack network
CVE-2026-30827GHSA-46wh-pxpv-q5gq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-rate-limit 8.2.2, 8.1.1, 8.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 8.2.0, < 8.2.2>= 8.1.0, <= 8.1.0>= 8.0.0, < 8.0.2
- Fixed in
- 8.0.2, 8.1.1, 8.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-46wh-pxpv-q5gq lists affected ranges: npm express-rate-limit >=8.2.0 =8.1.0 =8.0.0 <8.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-46wh-pxpv-q5gq lists affected ranges: npm express-rate-limit >=8.2.0 =8.1.0 =8.0.0 <8.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-30827: 0.52% estimated exploitation activity in the next 30 days; percentile 44.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The default keyGenerator in express-rate-limit applies IPv6 subnet masking (/56 by default) to all addresses that net.isIPv6() returns true for. This includes IPv4-mapped IPv6 addresses (::ffff:x.x.x.x), which Node.js returns as request.ip on dual-stack servers. Because the first 80 bits of all IPv4-mapped addresses are zero, a /56 (or any /32 to /80) subnet mask produces the same network key (::/56) for every IPv4 client. This collapses all IPv4 traffic into a single rate-limit bucket: one client exhausting the limit causes HTTP 429 for all other IPv4 clients. Details Root Cause In source/ip-key-generator.ts: net.isIPv6('::ffff:192.168.1.1') returns true, so IPv4-mapped addresses enter the subnet masking path. With a /56 prefix, the start address for any ::ffff:x.x.x.x is ::, producing the key ::/56. Proof of Concept End-to-End Validation On a dual-stack Express server (app.listen(port, '::')), tested with Express 5.2.1: - request.ip for IPv4 clients is ::ffff:127.0.0.1 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-46wh-pxpv-q5gq
- Revision 1 · created ·
Published from osv record GHSA-46wh-pxpv-q5gq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30827 Advisory: express-rate-limit: IPv4-mapped IPv6 addresses bypass per-client rate limiting on servers with dual-stack network IDs: CVE-2026-30827, GHSA-46wh-pxpv-q5gq Record: https://patchnext.com/advisories/cve-2026-30827 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express-rate-limit 8.2.2, 8.1.1, 8.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express-rate-limit: affected >= 8.2.0, < 8.2.2; >= 8.1.0, <= 8.1.0; >= 8.0.0, < 8.0.2; fixed in 8.0.2, 8.1.1, 8.2.2 ## Suggested inspection (read-only) - `npm ls express-rate-limit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express-rate-limit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-46wh-pxpv-q5gq (OSV record GHSA-46wh-pxpv-q5gq lists affected ranges: npm express-rate-limit >=8.2.0 =8.1.0 =8.0.0 <8.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-46wh-pxpv-q5gq (GitHub-reviewed advisory GHSA-46wh-pxpv-q5gq lists affected ranges: npm express-rate-limit >=8.2.0 =8.1.0 =8.0.0 <8.0.2) Commands are suggestions: review each one before running it.
Loading voting…