Skip to content

← Actionable
High, CVSS 7.7amended

Flowise Missing Authentication on NVIDIA NIM Endpoints

CVE-2026-30824GHSA-5f53-522j-j454

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.0.12
    Fixed in
    3.0.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-30824: 37.33% estimated exploitation activity in the next 30 days; percentile 98.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Missing Authentication on NVIDIA NIM Endpoints Summary The NVIDIA NIM router (/api/v1/nvidia-nim/) is whitelisted in the global authentication middleware, allowing unauthenticated access to privileged container management and token generation endpoints. Vulnerability Details | Field | Value | |-------|-------| | CWE | CWE-306: Missing Authentication for Critical Function | | Affected File | packages/server/src/utils/constants.ts | | Affected Line | Line 20 ('/api/v1/nvidia-nim' in WHITELISTURLS) | | CVSS 3.1 | 8.6 (High) | Root Cause In packages/server/src/utils/constants.ts, the NVIDIA NIM route is added to the authentication whitelist: This causes the global auth middleware to skip authentication checks for all endpoints under /api/v1/nvidia-nim/. None of the controller actions in packages/server/src/controllers/nvidia-nim/index.ts perform their own authentication checks. Affected Endpoints | Method | Endpoint | Risk | |--------|----------|------| | GET |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5f53-522j-j454

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5f53-522j-j454

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30824

Advisory: Flowise Missing Authentication on NVIDIA NIM Endpoints
IDs: CVE-2026-30824, GHSA-5f53-522j-j454
Record: https://patchnext.com/advisories/cve-2026-30824 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.0.12; fixed in 3.0.13

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5f53-522j-j454 (OSV record GHSA-5f53-522j-j454 lists affected ranges: npm flowise >=0 <3.0.13 (fixed))
- Verified: https://github.com/advisories/GHSA-5f53-522j-j454 (GitHub-reviewed advisory GHSA-5f53-522j-j454 lists affected ranges: npm flowise >=0 <=3.0.12)

Commands are suggestions: review each one before running it.

Loading voting…