Skip to content

← Actionable
High, CVSS 7.7amended

Flowise Allows Mass Assignment in /api/v1/leads Endpoint

CVE-2026-30822GHSA-mq4r-h2gh-qv7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.0.12
    Fixed in
    3.0.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-30822: 14.97% estimated exploitation activity in the next 30 days; percentile 96.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Mass Assignment vulnerability in the /api/v1/leads endpoint allows any unauthenticated user to control internal entity fields (id, createdDate, chatId) by including them in the request body. The endpoint uses Object.assign() to copy all properties from the request body to the Lead entity without any input validation or field filtering. This allows attackers to bypass auto-generated fields and inject arbitrary values. | Field | Value | |-------|-------| | Vulnerability Type | Mass Assignment | | CWE ID | CWE-915: Improperly Controlled Modification of Dynamically-Determined Object Attributes | | Authentication Required | None | | Affected Endpoint | POST /api/v1/leads | --- Details Root Cause The vulnerability exists in /packages/server/src/services/leads/index.ts at lines 27-28: The Object.assign(newLead, body) on line 28 copies ALL properties from the request body to the Lead entity, including: - id - The primary key (should be auto-generated) - createdDate - The creation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mq4r-h2gh-qv7x

  2. Revision 1 · created ·

    Published from osv record GHSA-mq4r-h2gh-qv7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30822

Advisory: Flowise Allows Mass Assignment in `/api/v1/leads` Endpoint
IDs: CVE-2026-30822, GHSA-mq4r-h2gh-qv7x
Record: https://patchnext.com/advisories/cve-2026-30822 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.0.12; fixed in 3.0.13

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mq4r-h2gh-qv7x (OSV record GHSA-mq4r-h2gh-qv7x lists affected ranges: npm flowise >=0 <3.0.13 (fixed))
- Verified: https://github.com/advisories/GHSA-mq4r-h2gh-qv7x (GitHub-reviewed advisory GHSA-mq4r-h2gh-qv7x lists affected ranges: npm flowise >=0 <=3.0.12)

Commands are suggestions: review each one before running it.

Loading voting…