Flowise has Authorization Bypass via Spoofed x-request-from Header
CVE-2026-30820GHSA-wvhq-wp8g-c7vq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise
- Affected
- <= 3.0.12
- Fixed in
- 3.0.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvhq-wp8g-c7vq lists affected ranges: npm flowise >=0 <3.0.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvhq-wp8g-c7vq lists affected ranges: npm flowise >=0 <=3.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-30820: 0.54% estimated exploitation activity in the next 30 days; percentile 45.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Flowise trusts any HTTP client that sets the header x-request-from: internal, allowing an authenticated tenant session to bypass all /api/v1/ authorization checks. With only a browser cookie, a low-privilege tenant can invoke internal administration endpoints (API key management, credential stores, custom function execution, etc.), effectively escalating privileges. Details The global middleware that guards /api/v1 routes lives in external/Flowise/packages/server/src/index.ts:214. After filtering out the whitelist, the logic short-circuits on the spoofable header: Because the middle branch blindly calls verifyToken, any tenant that already has a UI session cookie is treated as an internal client simply by adding that header. No additional permission checks are performed before next() executes, so every downstream router under /api/v1 becomes reachable. PoC 1. Log into Flowise 3.0.8 and capture cookies (e.g., curl -c /tmp/flowisecookies.txt … /api/v1/auth/login). 2. Invoke an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wvhq-wp8g-c7vq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wvhq-wp8g-c7vq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30820 Advisory: Flowise has Authorization Bypass via Spoofed x-request-from Header IDs: CVE-2026-30820, GHSA-wvhq-wp8g-c7vq Record: https://patchnext.com/advisories/cve-2026-30820 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise: affected <= 3.0.12; fixed in 3.0.13 ## Suggested inspection (read-only) - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvhq-wp8g-c7vq (OSV record GHSA-wvhq-wp8g-c7vq lists affected ranges: npm flowise >=0 <3.0.13 (fixed)) - Verified: https://github.com/advisories/GHSA-wvhq-wp8g-c7vq (GitHub-reviewed advisory GHSA-wvhq-wp8g-c7vq lists affected ranges: npm flowise >=0 <=3.0.12) Commands are suggestions: review each one before running it.
Loading voting…