Skip to content

← Actionable
High, CVSS 8.5amended

Plane has SSRF via Incomplete IP Validation in Webhook URL Serializer

CVE-2026-30242GHSA-fpx8-73gf-7x73

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (plane 1.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI plane

    Affected
    <= 1.2.1
    Fixed in
    1.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-30242: 0.38% estimated exploitation activity in the next 30 days; percentile 31.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The webhook URL validation in plane/app/serializers/webhook.py only checks ip.isloopback, allowing attackers with workspace ADMIN role to create webhooks pointing to private/internal network addresses (10.x.x.x, 172.16.x.x, 192.168.x.x, 169.254.169.254, etc.). When webhook events fire, the server makes requests to these internal addresses and stores the response — enabling SSRF with full response read-back. Impact - Cloud metadata exfiltration: Access AWS/GCP/Azure instance metadata (IAM credentials, tokens) - Internal service scanning: Probe internal network services not exposed to the internet - Data exfiltration via response logs: Full response body from internal services is stored and returned to the attacker through the webhook logs API - Bypass vectors: 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16, 169.254.0.0/16, 0.0.0.0, ::ffff: mapped addresses

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fpx8-73gf-7x73

  2. Revision 1 · created ·

    Published from osv record GHSA-fpx8-73gf-7x73

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30242

Advisory: Plane has SSRF via Incomplete IP Validation in Webhook URL Serializer
IDs: CVE-2026-30242, GHSA-fpx8-73gf-7x73
Record: https://patchnext.com/advisories/cve-2026-30242 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: plane 1.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI plane: affected <= 1.2.1; fixed in 1.2.3

## Suggested inspection (read-only)
- `python -m pip show plane`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on plane.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fpx8-73gf-7x73 (OSV record GHSA-fpx8-73gf-7x73 lists affected ranges: PyPI plane >=0 <1.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-fpx8-73gf-7x73 (GitHub-reviewed advisory GHSA-fpx8-73gf-7x73 lists affected ranges: PyPI plane >=0 <=1.2.1)

Commands are suggestions: review each one before running it.

Loading voting…