Skip to content

← Actionable
Low, CVSS 2.7amended

Mercurius's queryDepth limit bypassed for WebSocket subscriptions

CVE-2026-30241GHSA-m4h2-mjfm-mp55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mercurius 16.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-30241: 0.40% estimated exploitation activity in the next 30 days; percentile 34.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Mercurius fails to enforce the configured queryDepth limit on GraphQL subscription queries received over WebSocket connections. The depth check is correctly applied to HTTP queries and mutations, but subscription queries are parsed and executed without invoking the depth validation. This allows a remote client to submit arbitrarily deeply nested subscription queries over WebSocket, bypassing the intended depth restriction. On schemas with recursive types, this can lead to denial of service through exponential data resolution on each subscription event. Workarounds Disable subscriptions and, in general, queries over the WebSocket.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m4h2-mjfm-mp55

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m4h2-mjfm-mp55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30241

Advisory: Mercurius's queryDepth limit bypassed for WebSocket subscriptions
IDs: CVE-2026-30241, GHSA-m4h2-mjfm-mp55
Record: https://patchnext.com/advisories/cve-2026-30241 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mercurius 16.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mercurius: affected < 16.8.0; fixed in 16.8.0

## Suggested inspection (read-only)
- `npm ls mercurius --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mercurius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m4h2-mjfm-mp55 (OSV record GHSA-m4h2-mjfm-mp55 lists affected ranges: npm mercurius >=0 <16.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m4h2-mjfm-mp55 (GitHub-reviewed advisory GHSA-m4h2-mjfm-mp55 lists affected ranges: npm mercurius >=0 <16.8.0)

Commands are suggestions: review each one before running it.

Loading voting…