Skip to content

← Actionable
High, CVSS 8.5amended

parse-server's endpoint /loginAs allows readOnlyMasterKey to gain full read and write access as any user

CVE-2026-30229GHSA-79wj-8rqv-jvp5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.0-alpha.4, 8.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 8.6.6>= 9.0.0, < 9.5.0-alpha.4
    Fixed in
    9.5.0-alpha.4, 8.6.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-30229: 0.43% estimated exploitation activity in the next 30 days; percentile 37.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The readOnlyMasterKey can call POST /loginAs to obtain a valid session token for any user. This allows a read-only credential to impersonate arbitrary users with full read and write access to their data. Any Parse Server deployment that uses readOnlyMasterKey is affected. Patches The fix adds a check to the /logInAs handler. Workarounds There is no workaround other than not using readOnlyMasterKey. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-79wj-8rqv-jvp5 - Fix for Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.0-alpha.4 - Fix for Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.6

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-79wj-8rqv-jvp5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-79wj-8rqv-jvp5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30229

Advisory: parse-server's endpoint `/loginAs` allows `readOnlyMasterKey` to gain full read and write access as any user
IDs: CVE-2026-30229, GHSA-79wj-8rqv-jvp5
Record: https://patchnext.com/advisories/cve-2026-30229 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.0-alpha.4, 8.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 8.6.6; >= 9.0.0, < 9.5.0-alpha.4; fixed in 9.5.0-alpha.4, 8.6.6

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-79wj-8rqv-jvp5 (OSV record GHSA-79wj-8rqv-jvp5 lists affected ranges: npm parse-server >=0 =9.0.0 <9.5.0-alpha.4 (fixed))
- Verified: https://github.com/advisories/GHSA-79wj-8rqv-jvp5 (GitHub-reviewed advisory GHSA-79wj-8rqv-jvp5 lists affected ranges: npm parse-server >=0 =9.0.0 <9.5.0-alpha.4)

Commands are suggestions: review each one before running it.

Loading voting…