Skip to content

← Actionable
Low, CVSS 2.0amended

dbt-common's commonprefix() doesn't protect against path traversal

CVE-2026-29790GHSA-w75w-9qv4-j5xj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbt-common 1.37.3, 1.34.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dbt-common

    Affected
    < 1.34.2>= 1.35.0, < 1.37.3
    Fixed in
    1.37.3, 1.34.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-29790: 0.31% estimated exploitation activity in the next 30 days; percentile 23.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? A path traversal vulnerability exists in dbt-common's safeextract() function used when extracting tarball archives. The function uses os.path.commonprefix() to validate that extracted files remain within the intended destination directory. However, commonprefix() compares paths character-by-character rather than by path components, allowing a malicious tarball to write files to sibling directories with matching name prefixes. For example, when extracting to /tmp/packages, a crafted tarball could write files to /tmp/packagesevil/ by exploiting the character-based prefix matching. This vulnerability affects users who: - Install dbt packages from untrusted sources - Process tarball archives through dbt-common's extraction utilities The practical risk is limited because: - Exploitation requires a malicious tarball to be processed - File writes are restricted to sibling directories with matching prefixes (not arbitrary paths) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w75w-9qv4-j5xj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w75w-9qv4-j5xj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29790

Advisory: dbt-common's commonprefix() doesn't protect against path traversal
IDs: CVE-2026-29790, GHSA-w75w-9qv4-j5xj
Record: https://patchnext.com/advisories/cve-2026-29790 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dbt-common 1.37.3, 1.34.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dbt-common: affected < 1.34.2; >= 1.35.0, < 1.37.3; fixed in 1.37.3, 1.34.2

## Suggested inspection (read-only)
- `python -m pip show dbt-common`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dbt-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w75w-9qv4-j5xj (OSV record GHSA-w75w-9qv4-j5xj lists affected ranges: PyPI dbt-common >=0 =1.35.0 <1.37.3 (fixed))
- Verified: https://github.com/advisories/GHSA-w75w-9qv4-j5xj (GitHub-reviewed advisory GHSA-w75w-9qv4-j5xj lists affected ranges: PyPI dbt-common >=0 =1.35.0 <1.37.3)

Commands are suggestions: review each one before running it.

Loading voting…