Skip to content

← Actionable
High, CVSS 7.5amended

Ghost has incomplete CSRF protections around OTC use

CVE-2026-29784GHSA-9m84-wc28-w895

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.19.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 5.101.6, <= 6.19.2
    Fixed in
    6.19.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-29784: 0.19% estimated exploitation activity in the next 30 days; percentile 8.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Incomplete CSRF protections around /session/verify made it possible to use OTCs in login sessions different from the requesting session. In some scenarios this might have made it easier for phishers to take over a Ghost site. Vulnerable versions This vulnerability is present in Ghost from v5.101.6 up to v6.19.2. Patches v6.19.3 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If a project's Ghost is a Ghost-CLI install see the documentation on updating it to the latest version here. For more information If there are any questions or comments about this advisory, send an email to security@ghost.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9m84-wc28-w895

  2. Revision 1 · created ·

    Published from osv record GHSA-9m84-wc28-w895

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29784

Advisory: Ghost has incomplete CSRF protections around OTC use
IDs: CVE-2026-29784, GHSA-9m84-wc28-w895
Record: https://patchnext.com/advisories/cve-2026-29784 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.19.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 5.101.6, <= 6.19.2; fixed in 6.19.3

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9m84-wc28-w895 (OSV record GHSA-9m84-wc28-w895 lists affected ranges: npm ghost >=5.101.6 <6.19.3 (fixed))
- Verified: https://github.com/advisories/GHSA-9m84-wc28-w895 (GitHub-reviewed advisory GHSA-9m84-wc28-w895 lists affected ranges: npm ghost >=5.101.6 <=6.19.2)

Commands are suggestions: review each one before running it.

Loading voting…