GitHub Copilot CLI Dangerous Shell Expansion Patterns Enable Arbitrary Code Execution
CVE-2026-29783GHSA-g8r9-g2v8-jv6f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@github/copilot 0.0.423), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @github/copilot
- Affected
- <= 0.0.422
- Fixed in
- 0.0.423
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g8r9-g2v8-jv6f lists affected ranges: npm @github/copilot >=0 <0.0.423 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8r9-g2v8-jv6f lists affected ranges: npm @github/copilot >=0 <=0.0.422
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29783: 0.47% estimated exploitation activity in the next 30 days; percentile 40.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A security vulnerability has been identified in GitHub Copilot CLI's shell tool that could allow arbitrary code execution through crafted bash parameter expansion patterns. An attacker who can influence the commands executed by the agent (e.g., via prompt injection through repository files, MCP server responses, or user instructions) can exploit bash parameter transformation operators to execute hidden commands, bypassing the safety assessment that classifies commands as "read-only." Details The vulnerability stems from how the CLI's shell safety assessment evaluates commands before execution. The safety layer parses and classifies shell commands as either read-only (safe) or write-capable (requires user approval). However, several bash parameter expansion features can embed executable code within arguments to otherwise read-only commands, causing them to appear safe while actually performing arbitrary operations. The specific dangerous patterns are: 1. ${var@P} — Prompt…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g8r9-g2v8-jv6f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g8r9-g2v8-jv6f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29783 Advisory: GitHub Copilot CLI Dangerous Shell Expansion Patterns Enable Arbitrary Code Execution IDs: CVE-2026-29783, GHSA-g8r9-g2v8-jv6f Record: https://patchnext.com/advisories/cve-2026-29783 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @github/copilot 0.0.423. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @github/copilot: affected <= 0.0.422; fixed in 0.0.423 ## Suggested inspection (read-only) - `npm ls @github/copilot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @github/copilot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g8r9-g2v8-jv6f (OSV record GHSA-g8r9-g2v8-jv6f lists affected ranges: npm @github/copilot >=0 <0.0.423 (fixed)) - Verified: https://github.com/advisories/GHSA-g8r9-g2v8-jv6f (GitHub-reviewed advisory GHSA-g8r9-g2v8-jv6f lists affected ranges: npm @github/copilot >=0 <=0.0.422) Commands are suggestions: review each one before running it.
Loading voting…