eml_parser: Path Traversal in Official Example Script Leads to Arbitrary File Write
CVE-2026-29780GHSA-389r-rccm-h3h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (eml-parser 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI eml-parser
- Affected
- < 2.0.1
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-389r-rccm-h3h5 lists affected ranges: PyPI eml-parser >=0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-389r-rccm-h3h5 lists affected ranges: PyPI eml-parser >=0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-29780: 0.28% estimated exploitation activity in the next 30 days; percentile 20.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The official example script examples/recursivelyextractattachments.py contains a path traversal vulnerability that allows arbitrary file write outside the intended output directory. Attachment filenames extracted from parsed emails are directly used to construct output file paths without any sanitization, allowing an attacker-controlled filename to escape the target directory. Details File: examples/recursivelyextractattachments.py Lines: 61–64 The value a['filename'] is attacker-controlled via crafted email attachment headers: No path normalization or boundary validation is performed before writing. PoC 1. Create a malicious .eml file: 2. Run the example script: 3. Expected: ./safe/pwned.txt 4. Actual: ./outside/pwned.txt ← written outside the intended directory Verified on Kali Linux with emlparser installed via pip in a virtual environment. Impact This vulnerability is limited to the example script only and does not affect the core emlparser library. However, as the script…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-389r-rccm-h3h5
- Revision 1 · created ·
Published from osv record GHSA-389r-rccm-h3h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29780 Advisory: eml_parser: Path Traversal in Official Example Script Leads to Arbitrary File Write IDs: CVE-2026-29780, GHSA-389r-rccm-h3h5 Record: https://patchnext.com/advisories/cve-2026-29780 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: eml-parser 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI eml-parser: affected < 2.0.1; fixed in 2.0.1 ## Suggested inspection (read-only) - `python -m pip show eml-parser`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on eml-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-389r-rccm-h3h5 (OSV record GHSA-389r-rccm-h3h5 lists affected ranges: PyPI eml-parser >=0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-389r-rccm-h3h5 (GitHub-reviewed advisory GHSA-389r-rccm-h3h5 lists affected ranges: PyPI eml-parser >=0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…