Skip to content

← Actionable
High, CVSS 7.1amended

pyLoad has an Arbitrary File Write via Path Traversal in edit_package()

CVE-2026-29778GHSA-6px9-j4qr-xfjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev97), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    >= 0.5.0b3.dev13, <= 0.5.0b3.dev96
    Fixed in
    0.5.0b3.dev97

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-29778: 0.57% estimated exploitation activity in the next 30 days; percentile 47.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The editpackage() function implements insufficient sanitization for the packfolder parameter. The current protection relies on a single-pass string replacement of "../", which can be bypassed using crafted recursive traversal sequences. Exploitation An authenticated user with MODIFY permission can bypass the sanitization by submitting a payload such as: packfolder=..././..././..././tmp After the single-pass replacement, this becomes: ../../../tmp Because the traversal sequences are not properly validated, the resulting normalized path escapes the intended storage directory and writes files to /tmp or other locations.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6px9-j4qr-xfjw

  2. Revision 1 · created ·

    Published from osv record GHSA-6px9-j4qr-xfjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29778

Advisory: pyLoad has an Arbitrary File Write via Path Traversal in edit_package()
IDs: CVE-2026-29778, GHSA-6px9-j4qr-xfjw
Record: https://patchnext.com/advisories/cve-2026-29778 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev97. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected >= 0.5.0b3.dev13, <= 0.5.0b3.dev96; fixed in 0.5.0b3.dev97

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6px9-j4qr-xfjw (OSV record GHSA-6px9-j4qr-xfjw lists affected ranges: PyPI pyload-ng >=0.5.0b3.dev13 <0.5.0b3.dev97 (fixed))
- Verified: https://github.com/advisories/GHSA-6px9-j4qr-xfjw (GitHub-reviewed advisory GHSA-6px9-j4qr-xfjw lists affected ranges: PyPI pyload-ng >=0.5.0b3.dev13 <=0.5.0b3.dev96)

Commands are suggestions: review each one before running it.

Loading voting…