Netmaker Vulnerable to Denial of Service via Server Shutdown Endpoint
CVE-2026-29771GHSA-rhr9-hgcm-x289
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gravitl/netmaker 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gravitl/netmaker
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rhr9-hgcm-x289 lists affected ranges: Go github.com/gravitl/netmaker >=0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29771: 0.37% estimated exploitation activity in the next 30 days; percentile 31.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The /api/server/shutdown endpoint allows termination of the Netmaker server process via syscall.SIGINT. This allows any user to repeatedly shut down the server, causing cyclic denial of service with approximately 3-second restart intervals.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rhr9-hgcm-x289
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29771 Advisory: Netmaker Vulnerable to Denial of Service via Server Shutdown Endpoint IDs: CVE-2026-29771, GHSA-rhr9-hgcm-x289 Record: https://patchnext.com/advisories/cve-2026-29771 (revision 1, source checked 26 Oct 2026, 15:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gravitl/netmaker 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gravitl/netmaker: affected < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - Go github.com/gravitl/netmaker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gravitl/netmaker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rhr9-hgcm-x289 (GitHub-reviewed advisory GHSA-rhr9-hgcm-x289 lists affected ranges: Go github.com/gravitl/netmaker >=0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…