OpenClaw has a webhook auth bypass when gateway is behind a reverse proxy (loopback remoteAddress trust)
CVE-2026-29613GHSA-xc7w-v5x6-cc87
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.12
- Fixed in
- 2026.2.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xc7w-v5x6-cc87 lists affected ranges: npm openclaw >=0 <2026.2.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xc7w-v5x6-cc87 lists affected ranges: npm openclaw >=0 <2026.2.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29613: 0.46% estimated exploitation activity in the next 30 days; percentile 40.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The BlueBubbles webhook handler previously treated any request whose socket remoteAddress was loopback (127.0.0.1, ::1, ::ffff:127.0.0.1) as authenticated. When OpenClaw Gateway is behind a reverse proxy (Tailscale Serve/Funnel, nginx, Cloudflare Tunnel, ngrok), the proxy typically connects to the gateway over loopback, allowing unauthenticated remote requests to bypass the configured webhook password. This could allow an attacker who can reach the proxy endpoint to inject arbitrary inbound BlueBubbles message/reaction events. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: < 2026.2.12 - Patched versions: = 2026.2.12 Exposure / Configuration - BlueBubbles is an optional channel plugin (intended to eventually replace the legacy iMessage plugin, which is also optional). It is not enabled by default and is not part of a standard OpenClaw configuration. - Only deployments with the BlueBubbles webhook endpoint exposed through a reverse proxy are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xc7w-v5x6-cc87
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xc7w-v5x6-cc87
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29613 Advisory: OpenClaw has a webhook auth bypass when gateway is behind a reverse proxy (loopback remoteAddress trust) IDs: CVE-2026-29613, GHSA-xc7w-v5x6-cc87 Record: https://patchnext.com/advisories/cve-2026-29613 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.12. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.12; fixed in 2026.2.12 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xc7w-v5x6-cc87 (OSV record GHSA-xc7w-v5x6-cc87 lists affected ranges: npm openclaw >=0 <2026.2.12 (fixed)) - Verified: https://github.com/advisories/GHSA-xc7w-v5x6-cc87 (GitHub-reviewed advisory GHSA-xc7w-v5x6-cc87 lists affected ranges: npm openclaw >=0 <2026.2.12) Commands are suggestions: review each one before running it.
Loading voting…