Skip to content

← Actionable
Medium, CVSS 6.8amended

OpenClaw: denial of service through large base64 media files allocating large buffers before limit checks

CVE-2026-29612GHSA-w2cg-vxx6-5xjg

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14
  • npm clawdbot

    Affected
    <= 2026.1.24-3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-29612: 0.31% estimated exploitation activity in the next 30 days; percentile 24.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Base64-backed media inputs could be decoded into Buffers before enforcing decoded-size budgets. An attacker supplying oversized base64 payloads can force large allocations, causing memory pressure and denial of service. Attack Scenario Notes - Recommended deployments bind the gateway to loopback by default and require gateway auth for HTTP endpoints. In that configuration, this is best modeled as a local/authorized DoS. - If an operator exposes the gateway to untrusted networks (or disables/weakens auth and rate limits), treat this as a higher-severity network DoS risk. Affected Packages / Versions - openclaw (npm): <= 2026.2.13 - clawdbot (npm): <= 2026.1.24-3 Fixed In - openclaw (npm): 2026.2.14 (planned) - clawdbot (npm): no patched release planned; migrate to openclaw Fix Commit(s) - 31791233d60495725fa012745dde8d6ee69e9595 Credits Thanks @vincentkoc for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w2cg-vxx6-5xjg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w2cg-vxx6-5xjg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29612

Advisory: OpenClaw: denial of service through large base64 media files allocating large buffers before limit checks
IDs: CVE-2026-29612, GHSA-w2cg-vxx6-5xjg
Record: https://patchnext.com/advisories/cve-2026-29612 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14
- npm clawdbot: affected <= 2026.1.24-3

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw, clawdbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w2cg-vxx6-5xjg (OSV record GHSA-w2cg-vxx6-5xjg lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)
- Verified: https://github.com/advisories/GHSA-w2cg-vxx6-5xjg (GitHub-reviewed advisory GHSA-w2cg-vxx6-5xjg lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)

Commands are suggestions: review each one before running it.

Loading voting…