Skip to content

← Actionable
High, CVSS 7.5amended

OpenClaw affected by denial of service via unbounded URL-backed media fetch

CVE-2026-29609GHSA-j27p-hq53-9wgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-29609: 0.48% estimated exploitation activity in the next 30 days; percentile 41.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary URL-backed media fetch handling allocated the entire response payload in memory (arrayBuffer) before enforcing maxBytes, allowing oversized responses to cause memory exhaustion. Affected Versions - openclaw (npm): < 2026.2.14 - clawdbot (npm): <= 2026.1.24-3 Patched Versions - openclaw (npm): 2026.2.14 Fix Commit - openclaw/openclaw main: 00a08908892d1743d1fc52e5cbd9499dd5da2fe0 Details Affected component: - src/media/input-files.ts (fetchWithGuard) When content-length is missing or incorrect, reading the body via response.arrayBuffer() buffers the full payload before a size check can run. Proof of Concept 1. Configure URL-based media input. 2. Serve a response larger than maxBytes (chunked transfer / no content-length). 3. Trigger the fetchWithGuard URL fetch path. Example local server (large response): Impact Availability loss via memory pressure from attacker-controlled remote media responses. Mitigation Until a patched release is available, disable URL-backed media inputs…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j27p-hq53-9wgc

  2. Revision 1 · created ·

    Published from osv record GHSA-j27p-hq53-9wgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29609

Advisory: OpenClaw affected by denial of service via unbounded URL-backed media fetch
IDs: CVE-2026-29609, GHSA-j27p-hq53-9wgc
Record: https://patchnext.com/advisories/cve-2026-29609 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j27p-hq53-9wgc (OSV record GHSA-j27p-hq53-9wgc lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-j27p-hq53-9wgc (GitHub-reviewed advisory GHSA-j27p-hq53-9wgc lists affected ranges: npm openclaw >=0 <2026.2.14)

Commands are suggestions: review each one before running it.

Loading voting…