Skip to content

← Actionable
Medium, CVSS 6.7amended

OpenClaw's Node system.run approval hardening wrapper semantic drift can execute unintended local scripts

CVE-2026-29608GHSA-h3rm-6x7g-882f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2026.3.1, <= 2026.3.1
    Fixed in
    2026.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-29608: 0.14% estimated exploitation activity in the next 30 days; percentile 3.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In openclaw@2026.3.1, node system.run approval-path hardening rewrote wrapper command argv in a way that changed execution semantics. A command shown/approved as a shell payload (for example echo SAFE) could execute a different local script when wrapper argv were rewritten. Affected Packages / Versions - Package: openclaw (npm) - Affected: 2026.3.1 (latest published npm version as of March 2, 2026) - Fixed release: 2026.3.2 (released) Technical Details Root cause was in node-host approval hardening for system.run: - src/node-host/invoke-system-run-plan.ts rewrote argv[0] to the resolved executable. - Wrapper resolution unwrapped dispatch wrappers, so input like ['env','sh','-c','echo SAFE'] resolved executable sh. - The approved plan could become ['/bin/sh','sh','-c','echo SAFE'] while approval text remained echo SAFE. That rewrite changed runtime behavior: /bin/sh interprets the extra sh positional argument as a script path, enabling execution of a local ./sh file from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h3rm-6x7g-882f

  2. Revision 1 · created ·

    Published from osv record GHSA-h3rm-6x7g-882f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29608

Advisory: OpenClaw's Node system.run approval hardening wrapper semantic drift can execute unintended local scripts
IDs: CVE-2026-29608, GHSA-h3rm-6x7g-882f
Record: https://patchnext.com/advisories/cve-2026-29608 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2026.3.1, <= 2026.3.1; fixed in 2026.3.2

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3rm-6x7g-882f (OSV record GHSA-h3rm-6x7g-882f lists affected ranges: npm openclaw >=2026.3.1 <2026.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-h3rm-6x7g-882f (GitHub-reviewed advisory GHSA-h3rm-6x7g-882f lists affected ranges: npm openclaw >=2026.3.1 <=2026.3.1)

Commands are suggestions: review each one before running it.

Loading voting…