Skip to content

← Actionable
Medium, CVSS 6.4amended

OpenClaw's allow-always wrapper persistence could bypass future approvals and enable command execution

CVE-2026-29607GHSA-6j27-pc5c-m8w8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.22
    Fixed in
    2026.2.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-29607: 0.45% estimated exploitation activity in the next 30 days; percentile 38.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In openclaw npm releases up to and including 2026.2.21-2, approving wrapped system.run commands with allow-always in security=allowlist mode could persist wrapper-level allowlist entries and enable later approval-bypass execution of different inner payloads. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.21-2 - Planned patched version: 2026.2.22 Details allow-always persistence was based on wrapper-level resolution instead of stable inner executable intent. A benign approved wrapper invocation could therefore broaden future trust boundaries. Affected paths included gateway and node-host execution approval persistence flows. The fix now persists inner executable paths for known dispatch-wrapper chains (env, nice, nohup, stdbuf, timeout) and fails closed when safe unwrapping cannot be derived. Impact Authorization boundary bypass in allowlist mode, potentially leading to approval-free command execution (RCE class) on subsequent wrapped…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6j27-pc5c-m8w8

  2. Revision 1 · created ·

    Published from osv record GHSA-6j27-pc5c-m8w8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29607

Advisory: OpenClaw's allow-always wrapper persistence could bypass future approvals and enable command execution
IDs: CVE-2026-29607, GHSA-6j27-pc5c-m8w8
Record: https://patchnext.com/advisories/cve-2026-29607 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.22; fixed in 2026.2.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6j27-pc5c-m8w8 (OSV record GHSA-6j27-pc5c-m8w8 lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-6j27-pc5c-m8w8 (GitHub-reviewed advisory GHSA-6j27-pc5c-m8w8 lists affected ranges: npm openclaw >=0 <2026.2.22)

Commands are suggestions: review each one before running it.

Loading voting…