Netmaker has Privilege Escalation from Admin to Super-Admin via User Update
CVE-2026-29195GHSA-ch3w-9456-38v3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gravitl/netmaker 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gravitl/netmaker
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ch3w-9456-38v3 lists affected ranges: Go github.com/gravitl/netmaker >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29195: 0.26% estimated exploitation activity in the next 30 days; percentile 17.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The user update handler (PUT /api/users/{username}) lacks validation to prevent an admin-role user from assigning the super-admin role during account updates. While the code correctly blocks an admin from assigning the admin role to another user, it does not include an equivalent check for the super-admin role. Credits Artem Danilov (Positive Technologies)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ch3w-9456-38v3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29195 Advisory: Netmaker has Privilege Escalation from Admin to Super-Admin via User Update IDs: CVE-2026-29195, GHSA-ch3w-9456-38v3 Record: https://patchnext.com/advisories/cve-2026-29195 (revision 1, source checked 26 Oct 2026, 15:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gravitl/netmaker 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gravitl/netmaker: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - Go github.com/gravitl/netmaker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gravitl/netmaker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ch3w-9456-38v3 (GitHub-reviewed advisory GHSA-ch3w-9456-38v3 lists affected ranges: Go github.com/gravitl/netmaker >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…