Skip to content

← Actionable
High, CVSS 7.7amended

TechDocs Mkdocs Configuration Key Enables Arbitrary Code Execution

CVE-2026-29186GHSA-928r-fm4v-mvrw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-techdocs-node 1.14.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L
EPSS
  • CVE-2026-29186: 0.87% estimated exploitation activity in the next 30 days; percentile 58.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a configuration bypass vulnerability that enables arbitrary code execution. The @backstage/plugin-techdocs-node package uses an allowlist to filter dangerous MkDocs configuration keys during the documentation build process. A gap in this allowlist allows attackers to craft an mkdocs.yml that causes arbitrary Python code execution, completely bypassing TechDocs' security controls. Patches Patched in @backstage/plugin-techdocs-node version 1.14.3 Workarounds If users cannot upgrade immediately: 1. Use Docker mode with restricted access: Configure TechDocs with runIn: docker instead of runIn: local. This provides container isolation, though it does not fully mitigate the risk. 2. Restrict repository access: Limit who can modify mkdocs.yml files in repositories that TechDocs processes. Only allow trusted contributors. 3. Manual review: Implement PR review requirements for changes to mkdocs.yml files to detect malicious hooks configurations before they are merged. 4.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-928r-fm4v-mvrw

  2. Revision 1 · created ·

    Published from osv record GHSA-928r-fm4v-mvrw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29186

Advisory: TechDocs Mkdocs Configuration Key Enables Arbitrary Code Execution
IDs: CVE-2026-29186, GHSA-928r-fm4v-mvrw
Record: https://patchnext.com/advisories/cve-2026-29186 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-techdocs-node 1.14.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-techdocs-node: affected <= 1.14.2; fixed in 1.14.3

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-techdocs-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-techdocs-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-928r-fm4v-mvrw (OSV record GHSA-928r-fm4v-mvrw lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.14.3 (fixed))
- Verified: https://github.com/advisories/GHSA-928r-fm4v-mvrw (GitHub-reviewed advisory GHSA-928r-fm4v-mvrw lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <=1.14.2)

Commands are suggestions: review each one before running it.

Loading voting…