Backstage vulnerable to potential reading of SCM URLs using built in token
CVE-2026-29185GHSA-95v5-prp4-5gv5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/integration 1.20.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.20.0
- Fixed in
- 1.20.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-95v5-prp4-5gv5 lists affected ranges: npm @backstage/integration >=0 <1.20.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-95v5-prp4-5gv5 lists affected ranges: npm @backstage/integration >=0 <=1.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-29185: 0.40% estimated exploitation activity in the next 30 days; percentile 33.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in the SCM URL parsing used by Backstage integrations allowed path traversal sequences in encoded form to be included in file paths. When these URLs were processed by integration functions that construct API URLs, the traversal segments could redirect requests to unintended SCM provider API endpoints using the configured server-side integration credentials. This affects instances that use any of the SCM integrations (GitHub, Bitbucket Server, Bitbucket Cloud) with the scaffolder or other features that accept user-provided SCM URLs. Patches This is patched in @backstage/integration version 1.20.1. Workarounds There is no workaround for this vulnerability. Users should upgrade to the patched version. References - Backstage SCM integration documentation: https://backstage.io/docs/integrations/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-95v5-prp4-5gv5
- Revision 1 · created ·
Published from osv record GHSA-95v5-prp4-5gv5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29185 Advisory: Backstage vulnerable to potential reading of SCM URLs using built in token IDs: CVE-2026-29185, GHSA-95v5-prp4-5gv5 Record: https://patchnext.com/advisories/cve-2026-29185 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/integration 1.20.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/integration: affected <= 1.20.0; fixed in 1.20.1 ## Suggested inspection (read-only) - `npm ls @backstage/integration --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/integration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-95v5-prp4-5gv5 (OSV record GHSA-95v5-prp4-5gv5 lists affected ranges: npm @backstage/integration >=0 <1.20.1 (fixed)) - Verified: https://github.com/advisories/GHSA-95v5-prp4-5gv5 (GitHub-reviewed advisory GHSA-95v5-prp4-5gv5 lists affected ranges: npm @backstage/integration >=0 <=1.20.0) Commands are suggestions: review each one before running it.
Loading voting…