Parse Server's Cloud Hooks and Cloud Jobs bypass readOnlyMasterKey write restriction
CVE-2026-29182GHSA-vc89-5g3r-cmhh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.4.1-alpha.3, 8.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, <= 9.4.1-alpha.2<= 8.6.3
- Fixed in
- 9.4.1-alpha.3, 8.6.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vc89-5g3r-cmhh lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vc89-5g3r-cmhh lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29182: 0.43% estimated exploitation activity in the next 30 days; percentile 37.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Parse Server's readOnlyMasterKey option allows access with master-level read privileges but is documented to deny all write operations. However, some endpoints incorrectly accept the readOnlyMasterKey for mutating operations. This allows a caller who only holds the readOnlyMasterKey to create, modify, and delete Cloud Hooks and to start Cloud Jobs, which can be used for data exfiltration. Any Parse Server deployment that uses the readOnlyMasterKey option is affected. Note than an attacker needs to know the readOnlyMasterKey to exploit this vulnerability. Patches The fix adds authorization checks, rejecting mutating requests made with the readOnlyMasterKey. Workarounds There is no known workaround other than upgrading. If upgrading is not immediately possible, ensure the readOnlyMasterKey value is not shared with untrusted parties. Resources - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-vc89-5g3r-cmhh - Fixed in Parse…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vc89-5g3r-cmhh
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vc89-5g3r-cmhh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29182 Advisory: Parse Server's Cloud Hooks and Cloud Jobs bypass `readOnlyMasterKey` write restriction IDs: CVE-2026-29182, GHSA-vc89-5g3r-cmhh Record: https://patchnext.com/advisories/cve-2026-29182 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.4.1-alpha.3, 8.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, <= 9.4.1-alpha.2; <= 8.6.3; fixed in 9.4.1-alpha.3, 8.6.4 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vc89-5g3r-cmhh (OSV record GHSA-vc89-5g3r-cmhh lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.4 (fixed)) - Verified: https://github.com/advisories/GHSA-vc89-5g3r-cmhh (GitHub-reviewed advisory GHSA-vc89-5g3r-cmhh lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.3) Commands are suggestions: review each one before running it.
Loading voting…