October CMS: Editor Sub-Permission Bypass for Asset and Blueprint File Operations
CVE-2026-29179GHSA-jvwg-phxx-j3rp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 4.1.16, 3.7.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist october/system
- Affected
- >= 4.0.0, < 4.1.16< 3.7.16
- Fixed in
- 4.1.16, 3.7.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jvwg-phxx-j3rp lists affected ranges: Packagist october/system >=4.0.0 =0 <3.7.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-29179: 0.14% estimated exploitation activity in the next 30 days; percentile 3.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Fine-grained sub-permission checks for asset and blueprint file operations were not enforced in the CMS and Tailor editor extensions. This only affects backend users who were explicitly granted editor access but had editor.cmsassets or editor.tailorblueprints specifically withheld, an uncommon permission configuration. In this edge case, such users could perform file operations (create, delete, rename, move, upload) on theme assets or blueprint files despite lacking the required sub-permission. A related operator precedence error in the Tailor navigation also disclosed the theme blueprint directory tree under the same conditions. Impact - Only exploitable by authenticated backend users with editor access who have been specifically denied the editor.cmsassets or editor.tailorblueprints sub-permissions - Does not affect default permission configurations where editor users typically have all sub-permissions granted - Users without editor.cmsassets could manipulate theme asset files…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jvwg-phxx-j3rp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29179 Advisory: October CMS: Editor Sub-Permission Bypass for Asset and Blueprint File Operations IDs: CVE-2026-29179, GHSA-jvwg-phxx-j3rp Record: https://patchnext.com/advisories/cve-2026-29179 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: october/system 4.1.16, 3.7.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist october/system: affected >= 4.0.0, < 4.1.16; < 3.7.16; fixed in 4.1.16, 3.7.16 ## Suggested inspection (read-only) - Packagist october/system: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on october/system. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jvwg-phxx-j3rp (GitHub-reviewed advisory GHSA-jvwg-phxx-j3rp lists affected ranges: Packagist october/system >=4.0.0 =0 <3.7.16) Commands are suggestions: review each one before running it.
Loading voting…