Skip to content

← Actionable
High, CVSS 7.7

Lemmy has unauthenticated SSRF via file_type query parameter injection in image endpoint

CVE-2026-29178GHSA-jvxv-2jjp-jxc3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemmy_routes 0.19.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-29178: 0.29% estimated exploitation activity in the next 30 days; percentile 21.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The GET /api/v4/image/{filename} endpoint is vulnerable to unauthenticated SSRF through parameter injection in the filetype query parameter. An attacker can inject arbitrary query parameters into the internal request to pict-rs, including the proxy parameter which causes pict-rs to fetch arbitrary URLs. Affected code crates/routes/src/images/download.rs, lines 17-40 (getimage function): The filetype parameter (ImageGetParams.filetype: Option<String) is directly interpolated into the URL string without any validation or encoding. Since pict-rs's /image/process.{ext} endpoint supports a ?proxy={url} parameter for fetching remote images, an attacker can inject ?proxy=... via filetype to make pict-rs fetch arbitrary URLs. This endpoint does not require authentication (no LocalUserView extractor). PoC The response from the internal URL is streamed back to the attacker through pict-rs and Lemmy. Impact An unauthenticated attacker can: - Access cloud metadata services (AWS/GCP/Azure…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jvxv-2jjp-jxc3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29178

Advisory: Lemmy has unauthenticated SSRF via file_type query parameter injection in image endpoint
IDs: CVE-2026-29178, GHSA-jvxv-2jjp-jxc3
Record: https://patchnext.com/advisories/cve-2026-29178 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemmy_routes 0.19.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lemmy_routes: affected <= 0.19.15; fixed in 0.19.16

## Suggested inspection (read-only)
- crates.io lemmy_routes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemmy_routes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jvxv-2jjp-jxc3 (GitHub-reviewed advisory GHSA-jvxv-2jjp-jxc3 lists affected ranges: crates.io lemmy_routes >=0 <=0.19.15)

Commands are suggestions: review each one before running it.

Loading voting…