Skip to content

← Actionable
Low, CVSS 1.9

Craft Commerce has stored XSS in Craft Commerce Order Details Slideout

CVE-2026-29177GHSA-mj32-r678-7mvp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.3, 4.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/commerce

    Affected
    >= 4.0.0, <= 4.10.1>= 5.0.0, <= 5.5.2
    Fixed in
    4.10.2, 5.5.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-29177: 0.22% estimated exploitation activity in the next 30 days; percentile 13.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Stored Cross-Site Scripting (XSS) vulnerability exists in the Craft Commerce Order details. Malicious JavaScript can be injected via the Shipping Method Name, Order Reference, or Site Name. When a user opens the order details slideout via a double-click on the order index page, the injected payload executes. Reproduction Steps 1. Navigate to Commerce - Store Management - Shipping Methods. 1. Click "New Shipping Method". 1. In the Name field, enter the following XSS payload: 1. Save the Shipping Method. 1. Place a new order or edit an existing order. 1. Set the order's Shipping Method to the one created in the previous steps. 1. Navigate to the Orders index page (/admin/commerce/orders). 1. Double-click the target order to open the details slideout. 1. Result: The XSS payload executes.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mj32-r678-7mvp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29177

Advisory: Craft Commerce has stored XSS in Craft Commerce Order Details Slideout
IDs: CVE-2026-29177, GHSA-mj32-r678-7mvp
Record: https://patchnext.com/advisories/cve-2026-29177 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.3, 4.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/commerce: affected >= 4.0.0, <= 4.10.1; >= 5.0.0, <= 5.5.2; fixed in 4.10.2, 5.5.3

## Suggested inspection (read-only)
- Packagist craftcms/commerce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/commerce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mj32-r678-7mvp (GitHub-reviewed advisory GHSA-mj32-r678-7mvp lists affected ranges: Packagist craftcms/commerce >=4.0.0 =5.0.0 <=5.5.2)

Commands are suggestions: review each one before running it.

Loading voting…