Skip to content

← Actionable
Medium, CVSS 4.8

Craft Commerce has stored XSS in Inventory Location Name

CVE-2026-29176GHSA-wj89-2385-gpx3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-29176: 0.25% estimated exploitation activity in the next 30 days; percentile 16.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored XSS vulnerability exists in the Commerce Settings - Inventory Locations page. The Name field is rendered without proper HTML escaping, allowing an attacker to execute arbitrary JavaScript. This XSS triggers when an administrator (or user with product editing permissions) creates or edits a variant product. Proof of Concept Permissions Required - General - Access the control panel - Access Craft Commerce - Craft Commerce - Manage inventory locations Steps to Reproduce 1. Log in to the control panel 2. Navigate to Commerce → Inventory Locations 3. Create or edit a location 4. Set Name to the following payload: 5. Save the location 6. Navigate to Commerce → Products and click "New Product" and click "New product variant" 7. The Inventory Location table loads, rendering the Inventory Location Name 8. XSS executes Impact - Potential Session Hijacking - Potential Database Exfiltration - Potential Account Takeover by forcing a password change on the victim’s account. -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wj89-2385-gpx3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29176

Advisory: Craft Commerce has stored XSS in Inventory Location Name
IDs: CVE-2026-29176, GHSA-wj89-2385-gpx3
Record: https://patchnext.com/advisories/cve-2026-29176 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/commerce: affected >= 5.0.0, <= 5.5.2; fixed in 5.5.3

## Suggested inspection (read-only)
- Packagist craftcms/commerce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/commerce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wj89-2385-gpx3 (GitHub-reviewed advisory GHSA-wj89-2385-gpx3 lists affected ranges: Packagist craftcms/commerce >=5.0.0 <=5.5.2)

Commands are suggestions: review each one before running it.

Loading voting…