Skip to content

← Actionable
High, CVSS 8.7

Craft Commerce is vulnerable to SQL Injection in Commerce Inventory Table Sorting

CVE-2026-29174GHSA-pmgj-gmm4-jh6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-29174: 0.46% estimated exploitation activity in the next 30 days; percentile 40.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Craft Commerce is vulnerable to SQL Injection in the inventory levels table data endpoint. The sort[0][direction] and sort[0][sortField] parameters are concatenated directly into an addOrderBy() clause without any validation or sanitization. An authenticated attacker with access to the Commerce Inventory section can inject arbitrary SQL queries, potentially leading to a full database compromise. --- PoC Required Permissions - General - Access the control panel - Access Craft Commerce - Craft Commerce - Manage inventory stock levels Steps to reproduce 1. Log in to the control panel 2. Navigate to Commerce Inventory 3. Click on any sortable column header (e.g., "SKU") to trigger a sort request 4. Intercept the request and modify sort[0][direction] or sort[0][sortField] parameters and append ,sleep(2) payload to it's current value as follows: 6. Observe the delay in the response, confirming the injection Alternatively, you can use the following curl (bash syntax) command…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pmgj-gmm4-jh6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29174

Advisory: Craft Commerce is vulnerable to SQL Injection in Commerce Inventory Table Sorting
IDs: CVE-2026-29174, GHSA-pmgj-gmm4-jh6j
Record: https://patchnext.com/advisories/cve-2026-29174 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/commerce: affected >= 5.0.0, <= 5.5.2; fixed in 5.5.3

## Suggested inspection (read-only)
- Packagist craftcms/commerce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/commerce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pmgj-gmm4-jh6j (GitHub-reviewed advisory GHSA-pmgj-gmm4-jh6j lists affected ranges: Packagist craftcms/commerce >=5.0.0 <=5.5.2)

Commands are suggestions: review each one before running it.

Loading voting…