Craft Commerce is Vulnerable to Stored XSS while updating Order Status from Orders Table
CVE-2026-29173GHSA-mqxf-2998-c6cp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.3, 4.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/commerce
- Affected
- >= 4.0.0, <= 4.10.1>= 5.0.0, <= 5.5.2
- Fixed in
- 4.10.2, 5.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mqxf-2998-c6cp lists affected ranges: Packagist craftcms/commerce >=4.0.0 =5.0.0 <=5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-29173: 0.34% estimated exploitation activity in the next 30 days; percentile 27.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur. --- Proof of Concept Required Permissions - Admin access (to edit/create Order Statuses) Steps to Reproduce 1. Log in with an admin account 2. Navigate to Commerce → Settings → Order Statuses 3. Create a new order status 4. Set the Name field to: 5. Save the order status 6. Go to Commerce → Orders (make sure you placed any orders) 7. From the left panel, select any Order Status (e.g., New) 8. Select any order from the orders table → Click on the Gear Icon → then click "Update Order Status..." 9. Notice the XSS execution
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mqxf-2998-c6cp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29173 Advisory: Craft Commerce is Vulnerable to Stored XSS while updating Order Status from Orders Table IDs: CVE-2026-29173, GHSA-mqxf-2998-c6cp Record: https://patchnext.com/advisories/cve-2026-29173 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.3, 4.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/commerce: affected >= 4.0.0, <= 4.10.1; >= 5.0.0, <= 5.5.2; fixed in 4.10.2, 5.5.3 ## Suggested inspection (read-only) - Packagist craftcms/commerce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/commerce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mqxf-2998-c6cp (GitHub-reviewed advisory GHSA-mqxf-2998-c6cp lists affected ranges: Packagist craftcms/commerce >=4.0.0 =5.0.0 <=5.5.2) Commands are suggestions: review each one before running it.
Loading voting…