Craft Commerce is Vulnerable to SQL Injection in Commerce Purchasables Table Sorting
CVE-2026-29172GHSA-j3x5-mghf-xvfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.3, 4.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/commerce
- Affected
- >= 4.0.0, <= 4.10.1>= 5.0.0, <= 5.5.2
- Fixed in
- 4.10.2, 5.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3x5-mghf-xvfw lists affected ranges: Packagist craftcms/commerce >=4.0.0 =5.0.0 <=5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29172: 0.45% estimated exploitation activity in the next 30 days; percentile 38.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Craft Commerce is vulnerable to SQL Injection in the purchasables table endpoint. The sort parameter is split by | and the first part (column name) is passed directly as an array key to orderBy() without whitelist validation. Yii2's query builder does NOT escape array keys, allowing an authenticated attacker to inject arbitrary SQL into the ORDER BY clause. --- PoC Required Permissions - General - Access the control panel - Access Craft Commerce - Craft Commerce - Manage orders - Edit orders Steps to reproduce 1. Log in to the control panel 2. Navigate to Commerce Orders Create a new order 3. Click on "Add a line item" to show the purchasables table 4. Intercept the AJAX request and modify the sort parameter as follows: 5. Observe the delay in the response, confirming the injection Alternatively, you can use the following curl (bash syntax) command (replace cookie and target domain as needed): Impact With this Blind SQLi, an attacker can: - Exfiltrate data…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3x5-mghf-xvfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29172 Advisory: Craft Commerce is Vulnerable to SQL Injection in Commerce Purchasables Table Sorting IDs: CVE-2026-29172, GHSA-j3x5-mghf-xvfw Record: https://patchnext.com/advisories/cve-2026-29172 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.3, 4.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/commerce: affected >= 4.0.0, <= 4.10.1; >= 5.0.0, <= 5.5.2; fixed in 4.10.2, 5.5.3 ## Suggested inspection (read-only) - Packagist craftcms/commerce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/commerce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3x5-mghf-xvfw (GitHub-reviewed advisory GHSA-j3x5-mghf-xvfw lists affected ranges: Packagist craftcms/commerce >=4.0.0 =5.0.0 <=5.5.2) Commands are suggestions: review each one before running it.
Loading voting…