Skip to content

← Actionable
High, CVSS 8.7

Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor

CVE-2026-29146GHSA-h468-7pvh-8vr8

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-tribes

    Affected
    >= 9.0.13, < 9.0.116>= 10.1.50, < 10.1.53>= 11.0.0-M1, <= 11.0.18>= 8.5.38, <= 8.5.100>= 7.0.100, <= 7.0.109
    Fixed in
    11.0.20, 9.0.116, 10.1.53
  • Maven org.apache.tomcat:tomcat

    Affected
    >= 9.0.13, < 9.0.116>= 10.1.50, < 10.1.53>= 11.0.0-M1, <= 11.0.18>= 8.5.38, <= 8.5.100>= 7.0.100, <= 7.0.109
    Fixed in
    11.0.20, 9.0.116, 10.1.53

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-h468-7pvh-8vr8 lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.13 =10.1.50 =11.0.0-M1 =8.5.38 =7.0.100 =9.0.13 =10.1.50 =11.0.0-M1 =8.5.38 =7.0.100 <=7.0.109

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-29146: 8.85% estimated exploitation activity in the next 30 days; percentile 95.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h468-7pvh-8vr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29146

Advisory: Apache Tomcat: Padding Oracle vulnerability in EncryptInterceptor
IDs: CVE-2026-29146, GHSA-h468-7pvh-8vr8
Record: https://patchnext.com/advisories/cve-2026-29146 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-tribes 11.0.20, 10.1.53, 9.0.116; org.apache.tomcat:tomcat 11.0.20, 10.1.53, 9.0.116. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-tribes: affected >= 9.0.13, < 9.0.116; >= 10.1.50, < 10.1.53; >= 11.0.0-M1, <= 11.0.18; >= 8.5.38, <= 8.5.100; >= 7.0.100, <= 7.0.109; fixed in 11.0.20, 9.0.116, 10.1.53
- Maven org.apache.tomcat:tomcat: affected >= 9.0.13, < 9.0.116; >= 10.1.50, < 10.1.53; >= 11.0.0-M1, <= 11.0.18; >= 8.5.38, <= 8.5.100; >= 7.0.100, <= 7.0.109; fixed in 11.0.20, 9.0.116, 10.1.53

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-tribes: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-tribes, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h468-7pvh-8vr8 (GitHub-reviewed advisory GHSA-h468-7pvh-8vr8 lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.13 =10.1.50 =11.0.0-M1 =8.5.38 =7.0.100 =9.0.13 =10.1.50 =11.0.0-M1 =8.5.38 =7.0.100 <=7.0.109)

Commands are suggestions: review each one before running it.

Loading voting…