Apache Tomcat: Configured cipher preference order not preserved
CVE-2026-29129GHSA-69cc-cv78-qc8g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 11.0.20, 10.1.53, 9.0.116; org.apache.tomcat.embed:tomcat-embed-core 11.0.20, 10.1.53, 9.0.116; org.apache.tomcat:tomcat 11.0.20, 10.1.53, 9.0.116), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 9.0.114, < 9.0.116>= 10.1.51, < 10.1.53>= 11.0.16, < 11.0.20
- Fixed in
- 11.0.20, 9.0.116, 10.1.53
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 9.0.114, < 9.0.116>= 10.1.51, < 10.1.53>= 11.0.16, < 11.0.20
- Fixed in
- 11.0.20, 9.0.116, 10.1.53
Maven org.apache.tomcat:tomcat
- Affected
- >= 9.0.114, < 9.0.116>= 10.1.51, < 10.1.53>= 11.0.16, < 11.0.20
- Fixed in
- 11.0.20, 9.0.116, 10.1.53
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69cc-cv78-qc8g lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.114 =10.1.51 =11.0.16 =9.0.114 =10.1.51 =11.0.16 =9.0.114 =10.1.51 =11.0.16 <11.0.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-29129: 0.26% estimated exploitation activity in the next 30 days; percentile 17.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-69cc-cv78-qc8g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29129 Advisory: Apache Tomcat: Configured cipher preference order not preserved IDs: CVE-2026-29129, GHSA-69cc-cv78-qc8g Record: https://patchnext.com/advisories/cve-2026-29129 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.20, 10.1.53, 9.0.116; org.apache.tomcat.embed:tomcat-embed-core 11.0.20, 10.1.53, 9.0.116; org.apache.tomcat:tomcat 11.0.20, 10.1.53, 9.0.116. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 9.0.114, < 9.0.116; >= 10.1.51, < 10.1.53; >= 11.0.16, < 11.0.20; fixed in 11.0.20, 9.0.116, 10.1.53 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.114, < 9.0.116; >= 10.1.51, < 10.1.53; >= 11.0.16, < 11.0.20; fixed in 11.0.20, 9.0.116, 10.1.53 - Maven org.apache.tomcat:tomcat: affected >= 9.0.114, < 9.0.116; >= 10.1.51, < 10.1.53; >= 11.0.16, < 11.0.20; fixed in 11.0.20, 9.0.116, 10.1.53 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-69cc-cv78-qc8g (GitHub-reviewed advisory GHSA-69cc-cv78-qc8g lists affected ranges: Maven org.apache.tomcat:tomcat >=9.0.114 =10.1.51 =11.0.16 =9.0.114 =10.1.51 =11.0.16 =9.0.114 =10.1.51 =11.0.16 <11.0.20) Commands are suggestions: review each one before running it.
Loading voting…