Skip to content

← Actionable
High, CVSS 7.5amended

Uncontrolled memory allocation via crafted SVG dimensions in @dicebear/converter

CVE-2026-29112GHSA-v3r3-4qgc-vw66

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dicebear/converter 9.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-29112: 0.35% estimated exploitation activity in the next 30 days; percentile 28.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The ensureSize() function in @dicebear/converter (versions < 9.4.0) read the width and height attributes from the input SVG to determine the output canvas size for rasterization (PNG, JPEG, WebP, AVIF). An attacker who can supply a crafted SVG with extremely large dimensions (e.g. width="999999999") could force the server to allocate excessive memory, leading to denial of service. This primarily affects server-side applications that pass untrusted or user-supplied SVGs to the converter's toPng(), toJpeg(), toWebp(), or toAvif() functions. Applications that only convert self-generated DiceBear avatars are not practically exploitable, but are still recommended to upgrade. Patches Fixed in version 9.4.0. The ensureSize() function no longer reads SVG attributes to determine output size. Instead, a new size option (default: 512, max: 2048) controls the output dimensions. Invalid values (NaN, negative, zero, Infinity) fall back to the default. Workarounds If upgrading is not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v3r3-4qgc-vw66

  2. Revision 1 · created ·

    Published from osv record GHSA-v3r3-4qgc-vw66

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29112

Advisory: Uncontrolled memory allocation via crafted SVG dimensions in @dicebear/converter
IDs: CVE-2026-29112, GHSA-v3r3-4qgc-vw66
Record: https://patchnext.com/advisories/cve-2026-29112 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @dicebear/converter 9.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @dicebear/converter: affected < 9.4.0; fixed in 9.4.0

## Suggested inspection (read-only)
- `npm ls @dicebear/converter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @dicebear/converter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v3r3-4qgc-vw66 (OSV record GHSA-v3r3-4qgc-vw66 lists affected ranges: npm @dicebear/converter >=0 <9.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v3r3-4qgc-vw66 (GitHub-reviewed advisory GHSA-v3r3-4qgc-vw66 lists affected ranges: npm @dicebear/converter >=0 <9.4.0)

Commands are suggestions: review each one before running it.

Loading voting…